Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 08, 2025 - 19:30 UTC
Scheduled
We’re enhancing our backup and recovery infrastructure. Services will remain available; minor performance fluctuations may be observed during the window.
Posted Oct 08, 2025 - 11:13 UTC
This scheduled maintenance affected: EU (nFuse web application, nFuse order processing API, nFuse authentication & authorization service, Azure OpenAI EU data zone).